summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg_0.1.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg_0.1.8.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg_0.1.8.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg_0.1.8.bb b/meta/recipes-devtools/opkg/opkg_0.1.8.bb
new file mode 100644
index 0000000000..4eb3ff9a11
--- /dev/null
+++ b/meta/recipes-devtools/opkg/opkg_0.1.8.bb
@@ -0,0 +1,53 @@
1require opkg.inc
2
3PROVIDES += "virtual/update-alternatives"
4RPROVIDES_update-alternatives-cworth += "update-alternatives"
5RCONFLICTS_update-alternatives-cworth = "update-alternatives-dpkg"
6RDEPENDS_${PN} = "${VIRTUAL-RUNTIME_update-alternatives} opkg-config-base"
7RDEPENDS_${PN}_virtclass-native = ""
8RDEPENDS_${PN}_virtclass-nativesdk = ""
9PACKAGE_ARCH_update-alternatives-cworth = "all"
10
11SRC_URI = "http://opkg.googlecode.com/files/opkg-${PV}.tar.gz \
12 file://add_vercmp.patch \
13 file://headerfix.patch \
14"
15
16PR = "r3"
17
18PACKAGES =+ "libopkg-dev libopkg update-alternatives-cworth"
19
20FILES_update-alternatives-cworth = "${bindir}/update-alternatives"
21FILES_libopkg-dev = "${libdir}/*.a ${libdir}/*.la ${libdir}/*.so"
22FILES_libopkg = "${libdir}/*.so.* ${localstatedir}/lib/opkg/"
23
24# We need to create the lock directory
25do_install_append() {
26 install -d ${D}${localstatedir}/lib/opkg
27}
28
29# Define a variable to allow distros to run configure earlier.
30# (for example, to enable loading of ethernet kernel modules before networking starts)
31OPKG_INIT_POSITION = "98"
32OPKG_INIT_POSITION_slugos = "41"
33
34pkg_postinst_${PN} () {
35#!/bin/sh
36if [ "x$D" != "x" ]; then
37 install -d ${IMAGE_ROOTFS}/${sysconfdir}/rcS.d
38 # this happens at S98 where our good 'ole packages script used to run
39 echo "#!/bin/sh
40opkg-cl configure
41rm -f /${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
42" > $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
43 chmod 0755 $D${sysconfdir}/rcS.d/S${OPKG_INIT_POSITION}configure
44fi
45
46update-alternatives --install ${bindir}/opkg opkg ${bindir}/opkg-cl 100
47}
48
49pkg_postrm_${PN} () {
50#!/bin/sh
51update-alternatives --remove opkg ${bindir}/opkg-cl
52}
53