summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg-config-base_1.0.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg-config-base_1.0.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb b/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
new file mode 100644
index 0000000000..acbe1296bf
--- /dev/null
+++ b/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb
@@ -0,0 +1,30 @@
1SUMMARY = "Base configuration files for opkg"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4PACKAGE_ARCH = "${MACHINE_ARCH}"
5PR = "r1"
6
7do_compile() {
8 mkdir -p ${S}/${sysconfdir}/opkg/
9
10 archconf=${S}/${sysconfdir}/opkg/arch.conf
11
12 rm -f $archconf
13 ipkgarchs="${ALL_MULTILIB_PACKAGE_ARCHS}"
14 priority=1
15 for arch in $ipkgarchs; do
16 echo "arch $arch $priority" >> $archconf
17 priority=$(expr $priority + 5)
18 done
19}
20
21
22do_install () {
23 install -d ${D}${sysconfdir}/opkg
24 install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/
25}
26
27FILES_${PN} = "${sysconfdir}/opkg/ "
28
29CONFFILES_${PN} += "${sysconfdir}/opkg/arch.conf"
30