diff options
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg-config-base_1.0.bb')
-rw-r--r-- | meta/recipes-devtools/opkg/opkg-config-base_1.0.bb | 29 |
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb b/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb new file mode 100644 index 0000000000..9e27e9343f --- /dev/null +++ b/meta/recipes-devtools/opkg/opkg-config-base_1.0.bb | |||
@@ -0,0 +1,29 @@ | |||
1 | DESCRIPTION = "Base configuration files for opkg" | ||
2 | LICENSE = "MIT" | ||
3 | |||
4 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
5 | |||
6 | do_compile() { | ||
7 | mkdir -p ${S}/${sysconfdir}/opkg/ | ||
8 | |||
9 | archconf=${S}/${sysconfdir}/opkg/arch.conf | ||
10 | |||
11 | rm -f $archconf | ||
12 | ipkgarchs="${PACKAGE_ARCHS}" | ||
13 | priority=1 | ||
14 | for arch in $ipkgarchs; do | ||
15 | echo "arch $arch $priority" >> $archconf | ||
16 | priority=$(expr $priority + 5) | ||
17 | done | ||
18 | } | ||
19 | |||
20 | |||
21 | do_install () { | ||
22 | install -d ${D}${sysconfdir}/opkg | ||
23 | install -m 0644 ${S}/${sysconfdir}/opkg/* ${D}${sysconfdir}/opkg/ | ||
24 | } | ||
25 | |||
26 | FILES_${PN} = "${sysconfdir}/opkg/ " | ||
27 | |||
28 | CONFFILES_${PN} += "${sysconfdir}/opkg/arch.conf" | ||
29 | |||