summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg/opkg-collateral.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg/opkg-collateral.bb')
-rw-r--r--meta/recipes-devtools/opkg/opkg-collateral.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg/opkg-collateral.bb b/meta/recipes-devtools/opkg/opkg-collateral.bb
new file mode 100644
index 0000000000..b121827ac7
--- /dev/null
+++ b/meta/recipes-devtools/opkg/opkg-collateral.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Constructs the main configuration file for opkg"
2SECTION = "base"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
5PR = "r2"
6
7SRC_URI = "file://opkg.conf.comments \
8 file://dest \
9 file://src "
10
11OPKGLIBDIR = "${localstatedir}/lib"
12do_compile () {
13 cat ${WORKDIR}/opkg.conf.comments >${WORKDIR}/opkg.conf
14 cat ${WORKDIR}/src >>${WORKDIR}/opkg.conf
15 cat ${WORKDIR}/dest >>${WORKDIR}/opkg.conf
16 echo "lists_dir ext ${OPKGLIBDIR}/opkg" >>${WORKDIR}/opkg.conf
17}
18
19do_install () {
20 install -d ${D}${sysconfdir}/opkg
21 install -m 0644 ${WORKDIR}/opkg.conf ${D}${sysconfdir}/opkg/opkg.conf
22}
23
24CONFFILES_${PN} = "${sysconfdir}/opkg/opkg.conf"