summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
new file mode 100644
index 0000000000..f3b6f1f4cb
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_svn.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "OPKG Package Manager Utilities"
2SECTION = "base"
3HOMEPAGE = "http://wiki.openmoko.org/wiki/Opkg"
4PRIORITY = "optional"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
8RDEPENDS = "python"
9RDEPENDS_virtclass-native = ""
10PR = "r1"
11
12SRC_URI = "svn://svn.openmoko.org/trunk/src/host/;module=opkg-utils;proto=http \
13 file://index-ignore-filenotfound.patch"
14
15S = "${WORKDIR}/opkg-utils"
16
17# Avoid circular dependencies from package_ipk.bbclass
18PACKAGES_virtclass-native = ""
19
20do_install() {
21 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
22}
23
24BBCLASSEXTEND = "native"