summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg-utils/opkg-utils_git.bb')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb64
1 files changed, 0 insertions, 64 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
deleted file mode 100644
index ed5980b858..0000000000
--- a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
+++ /dev/null
@@ -1,64 +0,0 @@
1SUMMARY = "Additional utilities for the opkg package manager"
2SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system"
3SECTION = "base"
4HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=2;endline=18;md5=63ce9e6bcc445181cd9e4baf4b4ccc35"
8PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
9
10SRCREV = "1a708fd73d10c2b7677dd4cc4e017746ebbb9166"
11PV = "0.3.4+git${SRCPV}"
12
13SRC_URI = "git://git.yoctoproject.org/opkg-utils \
14 file://0001-Switch-all-scripts-to-use-Python-3.x.patch \
15"
16SRC_URI_append_class-native = " file://tar_ignore_error.patch"
17
18S = "${WORKDIR}/git"
19
20TARGET_CC_ARCH += "${LDFLAGS}"
21
22# For native builds we use the host Python
23PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-subprocess python3-pickle python3-compression python3-textutils python3-stringold"
24PYTHONRDEPS_class-native = ""
25
26PACKAGECONFIG = "python update-alternatives"
27PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
28PACKAGECONFIG[update-alternatives] = ",,,"
29
30do_install() {
31 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
32 if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
33 rm -f "${D}${bindir}/update-alternatives"
34 fi
35
36 if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
37 grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
38 fi
39}
40
41do_install_append_class-target() {
42 if [ -e "${D}${bindir}/update-alternatives" ]; then
43 sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
44 fi
45}
46
47# These are empty and will pull python3-dev into images where it wouldn't
48# have been otherwise, so don't generate them.
49PACKAGES_remove = "${PN}-dev ${PN}-staticdev"
50
51PACKAGES =+ "update-alternatives-opkg"
52FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
53RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
54RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
55RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
56
57pkg_postrm_update-alternatives-opkg() {
58 rm -rf $D${nonarch_libdir}/opkg/alternatives
59 rmdir $D${nonarch_libdir}/opkg || true
60}
61
62BBCLASSEXTEND = "native nativesdk"
63
64CLEANBROKEN = "1"