summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg-utils/opkg-utils_git.bb')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_git.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
new file mode 100644
index 0000000000..d2dfda6400
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_git.bb
@@ -0,0 +1,31 @@
1DESCRIPTION = "OPKG Package Manager Utilities"
2SECTION = "base"
3HOMEPAGE = "http://wiki.openmoko.org/wiki/Opkg"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
6 file://opkg.py;beginline=1;endline=18;md5=15917491ad6bf7acc666ca5f7cc1e083"
7RDEPENDS_${PN} = "python"
8RDEPENDS_${PN}_virtclass-native = ""
9SRCREV = "002d29bc605d7c2d02e4cf20a43c5277c15f5597"
10PV = "0.1.8+git${SRCPV}"
11PR = "r0"
12
13SRC_URI = "git://git.yoctoproject.org/opkg-utils;protocol=git \
14 file://index-ignore-filenotfound.patch \
15 file://mtime-int.patch \
16 file://add-license-field.patch \
17 file://arfile_header_split.patch \
18 file://shebang.patch \
19 "
20
21S = "${WORKDIR}/git"
22
23# Avoid circular dependencies from package_ipk.bbclass
24PACKAGES_virtclass-native = ""
25
26do_install() {
27 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
28}
29
30BBCLASSEXTEND = "native"
31TARGET_CC_ARCH += "${LDFLAGS}"