summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb65
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
new file mode 100644
index 0000000000..eb88b9b734
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.6.2.bb
@@ -0,0 +1,65 @@
1SUMMARY = "Additional utilities for the opkg package manager"
2SUMMARY:update-alternatives-opkg = "Utility for managing the alternatives system"
3SECTION = "base"
4HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
5LICENSE = "GPL-2.0-or-later"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=2;endline=18;md5=ffa11ff3c15eb31c6a7ceaa00cc9f986"
8PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
9
10SRC_URI = "git://git.yoctoproject.org/opkg-utils;protocol=https;branch=master \
11 file://0001-update-alternatives-correctly-match-priority.patch \
12 "
13SRCREV = "67994e62dc598282830385da75ba9b1abbbda941"
14
15S = "${WORKDIR}/git"
16
17TARGET_CC_ARCH += "${LDFLAGS}"
18
19RDEPENDS:${PN} += "bash"
20
21inherit perlnative
22
23# For native builds we use the host Python
24PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
25PYTHONRDEPS:class-native = ""
26
27PACKAGECONFIG = "python update-alternatives"
28PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
29PACKAGECONFIG[update-alternatives] = ",,,"
30
31do_install() {
32 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
33 if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
34 rm -f "${D}${bindir}/update-alternatives"
35 fi
36}
37
38do_install:append:class-target() {
39 if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
40 grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
41 fi
42
43 if [ -e "${D}${bindir}/update-alternatives" ]; then
44 sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
45 fi
46}
47
48# These are empty and will pull python3-dev into images where it wouldn't
49# have been otherwise, so don't generate them.
50PACKAGES:remove = "${PN}-dev ${PN}-staticdev"
51
52PACKAGES =+ "update-alternatives-opkg"
53FILES:update-alternatives-opkg = "${bindir}/update-alternatives"
54RPROVIDES:update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
55RREPLACES:update-alternatives-opkg = "update-alternatives-cworth"
56RCONFLICTS:update-alternatives-opkg = "update-alternatives-cworth"
57
58pkg_postrm:update-alternatives-opkg() {
59 rm -rf $D${nonarch_libdir}/opkg/alternatives
60 rmdir $D${nonarch_libdir}/opkg || true
61}
62
63BBCLASSEXTEND = "native nativesdk"
64
65CLEANBROKEN = "1"