summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb')
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb63
1 files changed, 63 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb
new file mode 100644
index 0000000000..6495726500
--- /dev/null
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.4.2.bb
@@ -0,0 +1,63 @@
1SUMMARY = "Additional utilities for the opkg package manager"
2SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system"
3SECTION = "base"
4HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \
7 file://opkg.py;beginline=2;endline=18;md5=ffa11ff3c15eb31c6a7ceaa00cc9f986"
8PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}"
9
10SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \
11"
12UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/"
13
14SRC_URI[md5sum] = "cc210650644fcb9bba06ad5ec95a63ec"
15SRC_URI[sha256sum] = "5929ad87d541789e0b82d626db01a1201ac48df6f49f2262fcfb86cf815e5d6c"
16
17TARGET_CC_ARCH += "${LDFLAGS}"
18
19RDEPENDS_${PN} += "bash"
20
21# For native builds we use the host Python
22PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold"
23PYTHONRDEPS_class-native = ""
24
25PACKAGECONFIG = "python update-alternatives"
26PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}"
27PACKAGECONFIG[update-alternatives] = ",,,"
28
29do_install() {
30 oe_runmake PREFIX=${prefix} DESTDIR=${D} install
31 if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then
32 rm -f "${D}${bindir}/update-alternatives"
33 fi
34
35 if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then
36 grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm
37 fi
38}
39
40do_install_append_class-target() {
41 if [ -e "${D}${bindir}/update-alternatives" ]; then
42 sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g'
43 fi
44}
45
46# These are empty and will pull python3-dev into images where it wouldn't
47# have been otherwise, so don't generate them.
48PACKAGES_remove = "${PN}-dev ${PN}-staticdev"
49
50PACKAGES =+ "update-alternatives-opkg"
51FILES_update-alternatives-opkg = "${bindir}/update-alternatives"
52RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth"
53RREPLACES_update-alternatives-opkg = "update-alternatives-cworth"
54RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth"
55
56pkg_postrm_update-alternatives-opkg() {
57 rm -rf $D${nonarch_libdir}/opkg/alternatives
58 rmdir $D${nonarch_libdir}/opkg || true
59}
60
61BBCLASSEXTEND = "native nativesdk"
62
63CLEANBROKEN = "1"