diff options
Diffstat (limited to 'meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb')
-rw-r--r-- | meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb | 66 |
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb b/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb new file mode 100644 index 0000000000..081d8d8b7d --- /dev/null +++ b/meta/recipes-devtools/opkg-utils/opkg-utils_0.3.6.bb | |||
@@ -0,0 +1,66 @@ | |||
1 | SUMMARY = "Additional utilities for the opkg package manager" | ||
2 | SUMMARY_update-alternatives-opkg = "Utility for managing the alternatives system" | ||
3 | SECTION = "base" | ||
4 | HOMEPAGE = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils" | ||
5 | LICENSE = "GPLv2+" | ||
6 | LIC_FILES_CHKSUM = "file://COPYING;md5=94d55d512a9ba36caa9b7df079bae19f \ | ||
7 | file://opkg.py;beginline=2;endline=18;md5=63ce9e6bcc445181cd9e4baf4b4ccc35" | ||
8 | PROVIDES += "${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'virtual/update-alternatives', '', d)}" | ||
9 | |||
10 | SRC_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/${BPN}/snapshot/${BPN}-${PV}.tar.gz \ | ||
11 | file://0001-Switch-all-scripts-to-use-Python-3.x.patch \ | ||
12 | file://0001-Only-use-sort-name-on-versions-of-tar-which-support-.patch \ | ||
13 | file://0002-opkg-build-Use-local-time-for-build_date-since-opkg-.patch \ | ||
14 | " | ||
15 | SRC_URI_append_class-native = " file://tar_ignore_error.patch" | ||
16 | UPSTREAM_CHECK_URI = "http://git.yoctoproject.org/cgit/cgit.cgi/opkg-utils/refs/" | ||
17 | |||
18 | |||
19 | SRC_URI[md5sum] = "391c1c80aca26961375dd22e1d2d0cbf" | ||
20 | SRC_URI[sha256sum] = "26b3f4dd1c1ef65f519d4cddfb35ebea41ae8af989aea2699a39783598c33769" | ||
21 | |||
22 | TARGET_CC_ARCH += "${LDFLAGS}" | ||
23 | |||
24 | # For native builds we use the host Python | ||
25 | PYTHONRDEPS = "python3 python3-shell python3-io python3-math python3-crypt python3-logging python3-fcntl python3-pickle python3-compression python3-stringold" | ||
26 | PYTHONRDEPS_class-native = "" | ||
27 | |||
28 | PACKAGECONFIG = "python update-alternatives" | ||
29 | PACKAGECONFIG[python] = ",,,${PYTHONRDEPS}" | ||
30 | PACKAGECONFIG[update-alternatives] = ",,," | ||
31 | |||
32 | do_install() { | ||
33 | oe_runmake PREFIX=${prefix} DESTDIR=${D} install | ||
34 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'update-alternatives', 'true', 'false', d)}; then | ||
35 | rm -f "${D}${bindir}/update-alternatives" | ||
36 | fi | ||
37 | |||
38 | if ! ${@bb.utils.contains('PACKAGECONFIG', 'python', 'true', 'false', d)}; then | ||
39 | grep -lZ "/usr/bin/env.*python" ${D}${bindir}/* | xargs -0 rm | ||
40 | fi | ||
41 | } | ||
42 | |||
43 | do_install_append_class-target() { | ||
44 | if [ -e "${D}${bindir}/update-alternatives" ]; then | ||
45 | sed -i ${D}${bindir}/update-alternatives -e 's,/usr/bin,${bindir},g; s,/usr/lib,${nonarch_libdir},g' | ||
46 | fi | ||
47 | } | ||
48 | |||
49 | # These are empty and will pull python3-dev into images where it wouldn't | ||
50 | # have been otherwise, so don't generate them. | ||
51 | PACKAGES_remove = "${PN}-dev ${PN}-staticdev" | ||
52 | |||
53 | PACKAGES =+ "update-alternatives-opkg" | ||
54 | FILES_update-alternatives-opkg = "${bindir}/update-alternatives" | ||
55 | RPROVIDES_update-alternatives-opkg = "update-alternatives update-alternatives-cworth" | ||
56 | RREPLACES_update-alternatives-opkg = "update-alternatives-cworth" | ||
57 | RCONFLICTS_update-alternatives-opkg = "update-alternatives-cworth" | ||
58 | |||
59 | pkg_postrm_update-alternatives-opkg() { | ||
60 | rm -rf $D${nonarch_libdir}/opkg/alternatives | ||
61 | rmdir $D${nonarch_libdir}/opkg || true | ||
62 | } | ||
63 | |||
64 | BBCLASSEXTEND = "native nativesdk" | ||
65 | |||
66 | CLEANBROKEN = "1" | ||