summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/opensp/opensp_1.5.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/opensp/opensp_1.5.2.bb')
-rw-r--r--meta/recipes-devtools/opensp/opensp_1.5.2.bb53
1 files changed, 53 insertions, 0 deletions
diff --git a/meta/recipes-devtools/opensp/opensp_1.5.2.bb b/meta/recipes-devtools/opensp/opensp_1.5.2.bb
new file mode 100644
index 0000000000..ecf8a3738b
--- /dev/null
+++ b/meta/recipes-devtools/opensp/opensp_1.5.2.bb
@@ -0,0 +1,53 @@
1SUMMARY = "An SGML parser"
2DESCRIPTION = "An SGML parser used by the OpenJade suite of utilities."
3HOMEPAGE = "http://openjade.sourceforge.net"
4SECTION = "libs"
5LICENSE = "BSD"
6LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
7
8PR = "r0"
9
10# At -Os it encounters calls to some inline functions which are then
11# not found in any other objects with gcc 4.5
12FULL_OPTIMIZATION += "-O2"
13
14SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/OpenSP-${PV}.tar.gz"
15
16SRC_URI[md5sum] = "670b223c5d12cee40c9137be86b6c39b"
17SRC_URI[sha256sum] = "57f4898498a368918b0d49c826aa434bb5b703d2c3b169beb348016ab25617ce"
18
19S = "${WORKDIR}/OpenSP-${PV}"
20
21inherit autotools gettext
22
23EXTRA_OECONF = "--disable-doc-build"
24
25EXTRA_OECONF_virtclass-native = "\
26 --disable-doc-build \
27 --enable-default-catalog=${sysconfdir}/sgml/catalog \
28 --enable-default-search-path=${datadir}/sgml \
29 "
30
31do_install_append() {
32 # Set up symlinks to often-used alternate names. See
33 # http://www.linuxfromscratch.org/blfs/view/stable/pst/opensp.html
34 cd ${D}${libdir}
35 ln -sf libosp.so libsp.so
36
37 cd ${D}${bindir}
38 for util in nsgmls sgmlnorm spam spcat spent sx; do
39 ln -sf o$util $util
40 done
41 ln -sf osx sgml2xml
42}
43
44do_install_append_virtclass-native() {
45 for util in nsgmls sgmlnorm spam spcat spent sx; do
46 create_cmdline_wrapper ${D}/${bindir}/$util \
47 -D ${sysconfdir}/sgml
48 done
49}
50
51FILES_${PN} += "${datadir}/OpenSP/"
52
53BBCLASSEXTEND = "native"