summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/openjade/openjade_1.3.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/openjade/openjade_1.3.2.bb')
-rw-r--r--meta/recipes-devtools/openjade/openjade_1.3.2.bb66
1 files changed, 66 insertions, 0 deletions
diff --git a/meta/recipes-devtools/openjade/openjade_1.3.2.bb b/meta/recipes-devtools/openjade/openjade_1.3.2.bb
new file mode 100644
index 0000000000..f2ad8aef7c
--- /dev/null
+++ b/meta/recipes-devtools/openjade/openjade_1.3.2.bb
@@ -0,0 +1,66 @@
1SUMMARY = "Tools for working with DSSSL stylesheets for SGML and XML documents"
2DESCRIPTION = "OpenJade is a suite of tools for validating, \
3processing, and applying DSSSL (Document Style Semantics and \
4Specification Language) stylesheets to SGML and XML documents."
5HOMEPAGE = "http://openjade.sourceforge.net"
6SECTION = "base"
7LICENSE = "BSD"
8LIC_FILES_CHKSUM = "file://COPYING;md5=641ff1e4511f0a87044ad42f87cb1045"
9
10PR = "r0"
11
12DEPENDS = "opensp"
13RDEPENDS_${PN} = "sgml-common"
14
15SRC_URI = "${SOURCEFORGE_MIRROR}/openjade/openjade-${PV}.tar.gz \
16 file://configure.patch \
17 file://autoconf.patch \
18 file://makefile.patch \
19 "
20
21SRC_URI[md5sum] = "7df692e3186109cc00db6825b777201e"
22SRC_URI[sha256sum] = "1d2d7996cc94f9b87d0c51cf0e028070ac177c4123ecbfd7ac1cb8d0b7d322d1"
23
24SRC_URI_append_virtclass-native = " file://oj-native-libosp-fix.patch"
25
26inherit autotools
27
28EXTRA_OECONF = "--enable-spincludedir=${STAGING_INCDIR}/OpenSP \
29 --enable-splibdir=${STAGING_LIBDIR}"
30
31acpaths = "-I ${S}/config"
32
33# Trailing whitespace is important. Otherwise compiler arguments will be messed
34# up, resulting in a fail in do_configure.
35CFLAGS_prepend = "-I${S}/include "
36
37do_configure_append () {
38 cp config/configure.in .
39}
40
41do_install_append () {
42 # Refer to http://www.linuxfromscratch.org/blfs/view/stable/pst/openjade.html
43 # for details.
44 install -m 0755 ${S}/jade/.libs/openjade ${D}${bindir}/openjade
45 ln -sf openjade ${D}${bindir}/jade
46
47 oe_libinstall -a -so -C style libostyle ${D}${libdir}
48 oe_libinstall -a -so -C spgrove libospgrove ${D}${libdir}
49 oe_libinstall -a -so -C grove libogrove ${D}${libdir}
50
51 install -d ${D}${datadir}/sgml/openjade-${PV}
52 install -m 644 dsssl/catalog ${D}${datadir}/sgml/openjade-${PV}
53 install -m 644 dsssl/*.{dtd,dsl,sgm} ${D}${datadir}/sgml/openjade-${PV}
54
55 # The catalog must live in the sysroot and it must be there for
56 # install-catalog to do its thing.
57 install -d ${datadir}/sgml/openjade-${PV}
58 install -m 644 dsssl/catalog ${datadir}/sgml/openjade-${PV}/catalog
59 install-catalog --add ${sysconfdir}/sgml/openjade-${PV}.cat \
60 ${datadir}/sgml/openjade-${PV}/catalog
61
62 install-catalog --add ${sysconfdir}/sgml/sgml-docbook.cat \
63 ${sysconfdir}/sgml/openjade-${PV}.cat
64}
65
66BBCLASSEXTEND = "native"