summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/ninja/ninja_1.9.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/ninja/ninja_1.9.0.bb')
-rw-r--r--meta/recipes-devtools/ninja/ninja_1.9.0.bb32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ninja/ninja_1.9.0.bb b/meta/recipes-devtools/ninja/ninja_1.9.0.bb
new file mode 100644
index 0000000000..1b06328961
--- /dev/null
+++ b/meta/recipes-devtools/ninja/ninja_1.9.0.bb
@@ -0,0 +1,32 @@
1SUMMARY = "Ninja is a small build system with a focus on speed."
2HOMEPAGE = "http://martine.github.com/ninja/"
3LICENSE = "Apache-2.0"
4LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e"
5
6DEPENDS = "re2c-native ninja-native"
7
8SRCREV = "b25c08bda4949192c69cea4cee057887341a2ffc"
9
10SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release \
11 file://fix-musl.patch \
12"
13UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)"
14
15S = "${WORKDIR}/git"
16
17do_configure[noexec] = "1"
18
19do_compile_class-native() {
20 ./configure.py --bootstrap
21}
22
23do_compile() {
24 ./configure.py
25 ninja
26}
27
28do_install() {
29 install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja
30}
31
32BBCLASSEXTEND = "native nativesdk"