diff options
Diffstat (limited to 'meta/recipes-devtools/ninja/ninja_1.8.2.bb')
-rw-r--r-- | meta/recipes-devtools/ninja/ninja_1.8.2.bb | 30 |
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ninja/ninja_1.8.2.bb b/meta/recipes-devtools/ninja/ninja_1.8.2.bb new file mode 100644 index 0000000000..c6fcfef3dd --- /dev/null +++ b/meta/recipes-devtools/ninja/ninja_1.8.2.bb | |||
@@ -0,0 +1,30 @@ | |||
1 | SUMMARY = "Ninja is a small build system with a focus on speed." | ||
2 | HOMEPAGE = "http://martine.github.com/ninja/" | ||
3 | LICENSE = "Apache-2.0" | ||
4 | LIC_FILES_CHKSUM = "file://COPYING;md5=a81586a64ad4e476c791cda7e2f2c52e" | ||
5 | |||
6 | DEPENDS = "re2c-native ninja-native" | ||
7 | |||
8 | SRCREV = "253e94c1fa511704baeb61cf69995bbf09ba435e" | ||
9 | |||
10 | SRC_URI = "git://github.com/ninja-build/ninja.git;branch=release" | ||
11 | UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>.*)" | ||
12 | |||
13 | S = "${WORKDIR}/git" | ||
14 | |||
15 | do_configure[noexec] = "1" | ||
16 | |||
17 | do_compile_class-native() { | ||
18 | ./configure.py --bootstrap | ||
19 | } | ||
20 | |||
21 | do_compile() { | ||
22 | ./configure.py | ||
23 | ninja | ||
24 | } | ||
25 | |||
26 | do_install() { | ||
27 | install -D -m 0755 ${S}/ninja ${D}${bindir}/ninja | ||
28 | } | ||
29 | |||
30 | BBCLASSEXTEND = "native nativesdk" | ||