summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.13.02.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.13.02.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.13.02.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.13.02.bb b/meta/recipes-devtools/nasm/nasm_2.13.02.bb
new file mode 100644
index 0000000000..15672abe7d
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.13.02.bb
@@ -0,0 +1,28 @@
1SUMMARY = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5
6SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
7
8SRC_URI[md5sum] = "f301c7ce89f28af9319edaf917365f61"
9SRC_URI[sha256sum] = "8d3028d286be7c185ba6ae4c8a692fc5438c129b2a3ffad60cbdcedd2793bbbe"
10
11inherit autotools-brokensep
12
13do_configure_prepend () {
14 if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
15 mv ${S}/aclocal.m4 ${S}/acinclude.m4
16 fi
17}
18
19do_install() {
20 install -d ${D}${bindir}
21 install -d ${D}${mandir}/man1
22
23 oe_runmake 'INSTALLROOT=${D}' install
24}
25
26BBCLASSEXTEND = "native"
27
28DEPENDS = "groff-native"