summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.11.06.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.11.06.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.11.06.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.11.06.bb b/meta/recipes-devtools/nasm/nasm_2.11.06.bb
new file mode 100644
index 0000000000..4a69a6a92e
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.11.06.bb
@@ -0,0 +1,29 @@
1SUMMARY = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
6
7
8SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
9SRC_URI[md5sum] = "9d93e8df5f5c005567f47ed6ca3a93d4"
10SRC_URI[sha256sum] = "87b6d97d6981ca468f9dafda44cf1bb1ba122cec329d4d389af5db04fa0c3e6c"
11
12inherit autotools-brokensep
13
14do_configure_prepend () {
15 if [ -f ${S}/aclocal.m4 ] && [ ! -f ${S}/acinclude.m4 ]; then
16 mv ${S}/aclocal.m4 ${S}/acinclude.m4
17 fi
18}
19
20do_install() {
21 install -d ${D}${bindir}
22 install -d ${D}${mandir}/man1
23
24 oe_runmake 'INSTALLROOT=${D}' install
25}
26
27BBCLASSEXTEND = "native"
28
29DEPENDS = "groff-native"