summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.10.06.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.10.06.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.10.06.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.10.06.bb b/meta/recipes-devtools/nasm/nasm_2.10.06.bb
new file mode 100644
index 0000000000..cb12a22dc0
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.10.06.bb
@@ -0,0 +1,30 @@
1DESCRIPTION = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
6
7PR = "r0"
8
9SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
10SRC_URI[md5sum] = "875c4217b2e581dbae0bf96d45a6067a"
11SRC_URI[sha256sum] = "ac84dd0d7e4ad6282061ce36b68a72db591db55cf0902b53d4297c743b0944a6"
12
13inherit autotools
14
15do_configure_prepend () {
16 if [ -f aclocal.m4 ] && [ ! -f acinclude.m4 ]; then
17 mv aclocal.m4 acinclude.m4
18 fi
19}
20
21do_install() {
22 install -d ${D}${bindir}
23 install -d ${D}${mandir}/man1
24
25 oe_runmake 'INSTALLROOT=${D}' install
26}
27
28BBCLASSEXTEND = "native"
29
30DEPENDS = "groff-native"