summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.10.01.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.10.01.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.10.01.bb28
1 files changed, 28 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.10.01.bb b/meta/recipes-devtools/nasm/nasm_2.10.01.bb
new file mode 100644
index 0000000000..8feaad43f4
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.10.01.bb
@@ -0,0 +1,28 @@
1DESCRIPTION = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "BSD-2-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=90904486f8fbf1861cf42752e1a39efe"
5COMPATIBLE_HOST = '(x86_64|i.86).*-(linux|freebsd.*)'
6
7PR = "r0"
8
9SRC_URI = "http://www.nasm.us/pub/nasm/releasebuilds/${PV}/nasm-${PV}.tar.bz2 "
10SRC_URI[md5sum] = "2e02cb6e90f52950eaaa8cce7a9f2327"
11SRC_URI[sha256sum] = "ac9b37d265c35492ab1bc29dd5a4f3da11b42dd9fea7a31d95f6cb4c812bda84"
12
13inherit autotools
14
15do_configure_prepend () {
16 if [ -f aclocal.m4 ] && [ ! -f acinclude.m4 ]; then
17 mv aclocal.m4 acinclude.m4
18 fi
19}
20
21do_install() {
22 install -d ${D}${bindir}
23 install -d ${D}${mandir}/man1
24
25 oe_runmake 'INSTALLROOT=${D}' install
26}
27
28BBCLASSEXTEND = "native"