summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/nasm/nasm_2.07.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/nasm/nasm_2.07.bb')
-rw-r--r--meta/recipes-devtools/nasm/nasm_2.07.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/nasm/nasm_2.07.bb b/meta/recipes-devtools/nasm/nasm_2.07.bb
new file mode 100644
index 0000000000..4e482a04d6
--- /dev/null
+++ b/meta/recipes-devtools/nasm/nasm_2.07.bb
@@ -0,0 +1,24 @@
1DESCRIPTION = "General-purpose x86 assembler"
2SECTION = "devel"
3LICENSE = "simplifiedBSD"
4LIC_CHKSUM_FILES = "file://LICENSE;md5=d89d124974e487e5d64da6f1cd8acfbb"
5COMPATIBLE_HOST = '(x86_64|i.86.*)-(linux|freebsd.*)'
6
7PR = "r0"
8
9SRC_URI = "${SOURCEFORGE_MIRROR}/nasm/nasm-${PV}.tar.bz2 "
10
11inherit autotools
12
13do_configure_prepend () {
14 mv aclocal.m4 acinclude.m4
15}
16
17do_install() {
18 install -d ${D}${bindir}
19 install -d ${D}${mandir}/man1
20
21 oe_runmake 'INSTALLROOT=${D}' install
22}
23
24BBCLASSEXTEND = "native"