summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mklibs/mklibs-native_0.1.39.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/mklibs/mklibs-native_0.1.39.bb')
-rw-r--r--meta/recipes-devtools/mklibs/mklibs-native_0.1.39.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mklibs/mklibs-native_0.1.39.bb b/meta/recipes-devtools/mklibs/mklibs-native_0.1.39.bb
new file mode 100644
index 0000000000..9885561fe3
--- /dev/null
+++ b/meta/recipes-devtools/mklibs/mklibs-native_0.1.39.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Shared library optimisation tool"
2DESCRIPTION = "mklibs produces cut-down shared libraries that contain only the routines required by a particular set of executables."
3HOMEPAGE = "https://launchpad.net/mklibs"
4SECTION = "devel"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://debian/copyright;md5=98d31037b13d896e33890738ef01af64"
7DEPENDS = "python-native dpkg-native"
8
9SRC_URI = "http://ftp.de.debian.org/debian/pool/main/m/mklibs/${BPN}_${PV}.tar.xz \
10 file://ac_init_fix.patch\
11 file://fix_STT_GNU_IFUNC.patch\
12 file://sysrooted-ldso.patch \
13"
14
15SRC_URI[md5sum] = "38a579a531401eb76f4bab4ccfb774a2"
16SRC_URI[sha256sum] = "fa2881ab4fe72b0504878357f1fc6b17920459b56e8a60dfb083ca28fb64e733"
17
18inherit autotools gettext native pythonnative
19
20do_configure_prepend() {
21 sed "s+MKLIBS_VERSION+${PV}+" ${S}/configure.ac
22}