summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mklibs/mklibs-native_0.1.37.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/mklibs/mklibs-native_0.1.37.bb')
-rw-r--r--meta/recipes-devtools/mklibs/mklibs-native_0.1.37.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mklibs/mklibs-native_0.1.37.bb b/meta/recipes-devtools/mklibs/mklibs-native_0.1.37.bb
new file mode 100644
index 0000000000..c37ea87457
--- /dev/null
+++ b/meta/recipes-devtools/mklibs/mklibs-native_0.1.37.bb
@@ -0,0 +1,20 @@
1DESCRIPTION = "mklibs produces cut-down shared libraries that contain only the routines required by a particular set of executables."
2HOMEPAGE = "https://code.launchpad.net/mklibs"
3SECTION = "devel"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=98d31037b13d896e33890738ef01af64"
6DEPENDS = "python-native"
7
8SRC_URI = "http://ftp.de.debian.org/debian/pool/main/m/mklibs/${BPN}_${PV}.tar.gz \
9 file://ac_init_fix.patch\
10 file://fix_STT_GNU_IFUNC.patch\
11"
12
13SRC_URI[md5sum] = "099cc99d51f09ea51e58a56e62a46af7"
14SRC_URI[sha256sum] = "9b2ef35618b1c2def1ca7a0a92c2b3029ef7f2080d894b6d1dbb3f313684d3a3"
15
16inherit autotools gettext native pythonnative
17
18do_configure_prepend() {
19 sed "s+MKLIBS_VERSION+${PV}+" ${S}/configure.ac
20}