summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mklibs/mklibs-native_0.1.34.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/mklibs/mklibs-native_0.1.34.bb')
-rw-r--r--meta/recipes-devtools/mklibs/mklibs-native_0.1.34.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mklibs/mklibs-native_0.1.34.bb b/meta/recipes-devtools/mklibs/mklibs-native_0.1.34.bb
new file mode 100644
index 0000000000..f2c303337e
--- /dev/null
+++ b/meta/recipes-devtools/mklibs/mklibs-native_0.1.34.bb
@@ -0,0 +1,22 @@
1DESCRIPTION = "mklibs produces cut-down shared libraries that contain only the routines required by a particular set of executables."
2HOMEPAGE = "https://code.launchpad.net/mklibs"
3SECTION = "devel"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=98d31037b13d896e33890738ef01af64"
6DEPENDS = "python-native"
7
8PR = "r0"
9
10SRC_URI = "http://ftp.de.debian.org/debian/pool/main/m/mklibs/${BPN}_${PV}.tar.gz \
11 file://ac_init_fix.patch\
12 file://fix_STT_GNU_IFUNC.patch\
13"
14
15SRC_URI[md5sum] = "afe0ed527ba96b8a882b5de350603007"
16SRC_URI[sha256sum] = "0c13c314f5c397529f58a5a02d57d83aeb4463d6a0d80b9374c6576ec37ed39f"
17
18inherit autotools gettext native
19
20do_configure_prepend() {
21 sed "s+MKLIBS_VERSION+${PV}+" ${S}/configure.ac
22}