summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/mklibs/mklibs-native_0.1.31.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/mklibs/mklibs-native_0.1.31.bb')
-rw-r--r--meta/recipes-devtools/mklibs/mklibs-native_0.1.31.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/mklibs/mklibs-native_0.1.31.bb b/meta/recipes-devtools/mklibs/mklibs-native_0.1.31.bb
new file mode 100644
index 0000000000..2044d125ef
--- /dev/null
+++ b/meta/recipes-devtools/mklibs/mklibs-native_0.1.31.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "mklibs produces cut-down shared libraries that contain only the routines required by a particular set of executables."
2HOMEPAGE = "https://code.launchpad.net/mklibs"
3SECTION = "devel"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://debian/copyright;md5=98d31037b13d896e33890738ef01af64"
6DEPENDS = "python-native"
7
8PR = "r0"
9
10SRC_URI = "http://ftp.de.debian.org/debian/pool/main/m/mklibs/${BPN}_${PV}.tar.gz \
11 file://ac_init_fix.patch\
12"
13
14SRC_URI[md5sum] = "f4df0307ccbdf60070e42277513f27ed"
15SRC_URI[sha256sum] = "8f5595621eb09d52871c771861e81b032d10c31d15e5dd61fa7f5a9e5b7de405"
16
17S = "${WORKDIR}/${BPN}"
18
19inherit autotools gettext native
20
21do_configure_prepend() {
22 sed "s+MKLIBS_VERSION+${PV}+" ${S}/configure.ac
23}