diff options
Diffstat (limited to 'meta/recipes-devtools/meson/nativesdk-meson_0.54.3.bb')
-rw-r--r-- | meta/recipes-devtools/meson/nativesdk-meson_0.54.3.bb | 65 |
1 files changed, 65 insertions, 0 deletions
diff --git a/meta/recipes-devtools/meson/nativesdk-meson_0.54.3.bb b/meta/recipes-devtools/meson/nativesdk-meson_0.54.3.bb new file mode 100644 index 0000000000..67add2c25e --- /dev/null +++ b/meta/recipes-devtools/meson/nativesdk-meson_0.54.3.bb | |||
@@ -0,0 +1,65 @@ | |||
1 | include meson.inc | ||
2 | |||
3 | inherit nativesdk | ||
4 | inherit siteinfo | ||
5 | |||
6 | SRC_URI += "file://meson-setup.py \ | ||
7 | file://meson-wrapper" | ||
8 | |||
9 | def meson_endian(prefix, d): | ||
10 | arch, os = d.getVar(prefix + "_ARCH"), d.getVar(prefix + "_OS") | ||
11 | sitedata = siteinfo_data_for_machine(arch, os, d) | ||
12 | if "endian-little" in sitedata: | ||
13 | return "little" | ||
14 | elif "endian-big" in sitedata: | ||
15 | return "big" | ||
16 | else: | ||
17 | bb.fatal("Cannot determine endianism for %s-%s" % (arch, os)) | ||
18 | |||
19 | # The cross file logic is similar but not identical to that in meson.bbclass, | ||
20 | # since it's generating for an SDK rather than a cross-compile. Important | ||
21 | # differences are: | ||
22 | # - We can't set vars like CC, CXX, etc. yet because they will be filled in with | ||
23 | # real paths by meson-setup.sh when the SDK is extracted. | ||
24 | # - Some overrides aren't needed, since the SDK injects paths that take care of | ||
25 | # them. | ||
26 | do_install_append() { | ||
27 | install -d ${D}${datadir}/meson | ||
28 | cat >${D}${datadir}/meson/meson.cross.template <<EOF | ||
29 | [binaries] | ||
30 | c = @CC | ||
31 | cpp = @CXX | ||
32 | ar = @AR | ||
33 | nm = @NM | ||
34 | strip = @STRIP | ||
35 | pkgconfig = 'pkg-config' | ||
36 | |||
37 | [properties] | ||
38 | needs_exe_wrapper = true | ||
39 | c_args = @CFLAGS | ||
40 | c_link_args = @LDFLAGS | ||
41 | cpp_args = @CPPFLAGS | ||
42 | cpp_link_args = @LDFLAGS | ||
43 | |||
44 | [host_machine] | ||
45 | system = '${SDK_OS}' | ||
46 | cpu_family = '${SDK_ARCH}' | ||
47 | cpu = '${SDK_ARCH}' | ||
48 | endian = '${@meson_endian("SDK", d)}' | ||
49 | EOF | ||
50 | |||
51 | install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d | ||
52 | install -m 0755 ${WORKDIR}/meson-setup.py ${D}${SDKPATHNATIVE}/post-relocate-setup.d/ | ||
53 | |||
54 | # We need to wrap the real meson with a thin env setup wrapper. | ||
55 | mv ${D}${bindir}/meson ${D}${bindir}/meson.real | ||
56 | install -m 0755 ${WORKDIR}/meson-wrapper ${D}${bindir}/meson | ||
57 | } | ||
58 | |||
59 | RDEPENDS_${PN} += "\ | ||
60 | nativesdk-ninja \ | ||
61 | nativesdk-python3 \ | ||
62 | nativesdk-python3-setuptools \ | ||
63 | " | ||
64 | |||
65 | FILES_${PN} += "${datadir}/meson ${SDKPATHNATIVE}" | ||