diff options
Diffstat (limited to 'meta/recipes-devtools/meson/nativesdk-meson_0.46.1.bb')
-rw-r--r-- | meta/recipes-devtools/meson/nativesdk-meson_0.46.1.bb | 74 |
1 files changed, 74 insertions, 0 deletions
diff --git a/meta/recipes-devtools/meson/nativesdk-meson_0.46.1.bb b/meta/recipes-devtools/meson/nativesdk-meson_0.46.1.bb new file mode 100644 index 0000000000..53503aa998 --- /dev/null +++ b/meta/recipes-devtools/meson/nativesdk-meson_0.46.1.bb | |||
@@ -0,0 +1,74 @@ | |||
1 | include meson.inc | ||
2 | |||
3 | inherit nativesdk | ||
4 | |||
5 | SRC_URI += "file://meson-setup.py \ | ||
6 | file://meson-wrapper" | ||
7 | |||
8 | def meson_array(var, d): | ||
9 | return "', '".join(d.getVar(var).split()).join(("'", "'")) | ||
10 | |||
11 | # both are required but not used by meson | ||
12 | MESON_SDK_ENDIAN = "bogus-endian" | ||
13 | MESON_TARGET_ENDIAN = "bogus-endian" | ||
14 | |||
15 | MESON_TOOLCHAIN_ARGS = "${BUILDSDK_CC_ARCH}${TOOLCHAIN_OPTIONS}" | ||
16 | MESON_C_ARGS = "${MESON_TOOLCHAIN_ARGS} ${BUILDSDK_CFLAGS}" | ||
17 | MESON_CPP_ARGS = "${MESON_TOOLCHAIN_ARGS} ${BUILDSDK_CXXFLAGS}" | ||
18 | MESON_LINK_ARGS = "${MESON_TOOLCHAIN_ARGS} ${BUILDSDK_LDFLAGS}" | ||
19 | |||
20 | # This logic is similar but not identical to that in meson.bbclass, since it's | ||
21 | # generating for an SDK rather than a cross-compile. Important differences are: | ||
22 | # - We can't set vars like CC, CXX, etc. yet because they will be filled in with | ||
23 | # real paths by meson-setup.sh when the SDK is extracted. | ||
24 | # - Some overrides aren't needed, since the SDK injects paths that take care of | ||
25 | # them. | ||
26 | addtask write_config before do_install | ||
27 | do_write_config[vardeps] += "MESON_C_ARGS MESON_CPP_ARGS MESON_LINK_ARGS CC CXX LD AR NM STRIP READELF" | ||
28 | do_write_config() { | ||
29 | # This needs to be Py to split the args into single-element lists | ||
30 | cat >${WORKDIR}/meson.cross <<EOF | ||
31 | [binaries] | ||
32 | c = @@CC@@ | ||
33 | cpp = @@CXX@@ | ||
34 | ar = @@AR@@ | ||
35 | nm = @@NM@@ | ||
36 | ld = @@LD@@ | ||
37 | strip = @@STRIP@@ | ||
38 | pkgconfig = 'pkg-config' | ||
39 | |||
40 | [properties] | ||
41 | needs_exe_wrapper = true | ||
42 | c_args = @@CFLAGS@@ | ||
43 | c_link_args = @@LDFLAGS@@ | ||
44 | cpp_args = @@CPPFLAGS@@ | ||
45 | cpp_link_args = @@LDFLAGS@@ | ||
46 | |||
47 | [host_machine] | ||
48 | system = '${SDK_OS}' | ||
49 | cpu_family = '${SDK_ARCH}' | ||
50 | cpu = '${SDK_ARCH}' | ||
51 | endian = '${MESON_SDK_ENDIAN}' | ||
52 | EOF | ||
53 | } | ||
54 | |||
55 | do_install_append() { | ||
56 | install -d ${D}${datadir}/meson | ||
57 | install -m 0644 ${WORKDIR}/meson.cross ${D}${datadir}/meson/ | ||
58 | |||
59 | install -d ${D}${SDKPATHNATIVE}/post-relocate-setup.d | ||
60 | install -m 0755 ${WORKDIR}/meson-setup.py ${D}${SDKPATHNATIVE}/post-relocate-setup.d/ | ||
61 | |||
62 | # We need to wrap the real meson with a thin env setup wrapper. | ||
63 | mv ${D}${bindir}/meson ${D}${bindir}/meson.real | ||
64 | install -m 0755 ${WORKDIR}/meson-wrapper ${D}${bindir}/meson | ||
65 | } | ||
66 | |||
67 | RDEPENDS_${PN} += "\ | ||
68 | nativesdk-ninja \ | ||
69 | nativesdk-python3-core \ | ||
70 | nativesdk-python3-misc \ | ||
71 | nativesdk-python3-modules \ | ||
72 | " | ||
73 | |||
74 | FILES_${PN} += "${datadir}/meson ${SDKPATHNATIVE}" | ||