summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/llvm/llvm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/llvm/llvm_git.bb')
-rw-r--r--meta/recipes-devtools/llvm/llvm_git.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta/recipes-devtools/llvm/llvm_git.bb b/meta/recipes-devtools/llvm/llvm_git.bb
index db6694339c..8a5d3dc9bf 100644
--- a/meta/recipes-devtools/llvm/llvm_git.bb
+++ b/meta/recipes-devtools/llvm/llvm_git.bb
@@ -19,8 +19,8 @@ inherit cmake pkgconfig
19 19
20PROVIDES += "llvm${PV}" 20PROVIDES += "llvm${PV}"
21 21
22MAJOR_VERSION = "11" 22MAJOR_VERSION = "12"
23MINOR_VERSION = "1" 23MINOR_VERSION = "0"
24PATCH_VERSION = "0" 24PATCH_VERSION = "0"
25 25
26PV = "${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}" 26PV = "${MAJOR_VERSION}.${MINOR_VERSION}.${PATCH_VERSION}"
@@ -29,12 +29,11 @@ LLVM_RELEASE = "${PV}"
29LLVM_DIR = "llvm${LLVM_RELEASE}" 29LLVM_DIR = "llvm${LLVM_RELEASE}"
30 30
31BRANCH = "release/${MAJOR_VERSION}.x" 31BRANCH = "release/${MAJOR_VERSION}.x"
32SRCREV = "1fdec59bffc11ae37eb51a1b9869f0696bfd5312" 32SRCREV = "fa0971b87fb2c9d14d1bba2551e61f02f18f329b"
33SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \ 33SRC_URI = "git://github.com/llvm/llvm-project.git;branch=${BRANCH} \
34 file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \ 34 file://0006-llvm-TargetLibraryInfo-Undefine-libc-functions-if-th.patch;striplevel=2 \
35 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \ 35 file://0007-llvm-allow-env-override-of-exe-path.patch;striplevel=2 \
36 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \ 36 file://0001-AsmMatcherEmitter-sort-ClassInfo-lists-by-name-as-we.patch;striplevel=2 \
37 file://0001-nfc-Fix-missing-include.patch;striplevel=2 \
38 " 37 "
39 38
40UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)" 39UPSTREAM_CHECK_GITTAGREGEX = "llvmorg-(?P<pver>\d+(\.\d+)+)"