summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool_2.2.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool_2.2.10.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool_2.2.10.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool_2.2.10.bb b/meta/recipes-devtools/libtool/libtool_2.2.10.bb
new file mode 100644
index 0000000000..9eaec2da67
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool_2.2.10.bb
@@ -0,0 +1,33 @@
1require libtool.inc
2DEPENDS = "libtool-native"
3
4PR = "r1"
5
6PACKAGES =+ "libltdl libltdl-dev libltdl-dbg"
7FILES_${PN} += "${datadir}/aclocal*"
8FILES_libltdl = "${libdir}/libltdl.so.*"
9FILES_libltdl-dev = "${libdir}/libltdl.* ${includedir}/ltdl.h"
10FILES_libltdl-dbg = "${libdir}/.debug/"
11
12inherit autotools
13
14EXTRA_AUTORECONF = "--exclude=libtoolize"
15
16do_compile_prepend () {
17 # Sometimes this file doesn't get rebuilt, force the issue
18 rm -f ${S}/libltdl/config/ltmain.sh
19 make libltdl/config/ltmain.sh
20}
21
22#
23# We want the results of libtool-cross preserved - don't stage anything ourselves.
24#
25SYSROOT_PREPROCESS_FUNCS += "libtool_sysroot_preprocess"
26
27libtool_sysroot_preprocess () {
28 if [ "${PN}" == "libtool" ]; then
29 rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${bindir}/*
30 rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/aclocal/*
31 rm -rf ${SYSROOT_DESTDIR}${STAGING_DIR_TARGET}${datadir}/libtool/config/*
32 fi
33}