summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb b/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb
new file mode 100644
index 0000000000..03854f22f3
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-nativesdk_2.4.2.bb
@@ -0,0 +1,27 @@
1require libtool-${PV}.inc
2
3PR = "${INC_PR}.0"
4SRC_URI += "file://prefix.patch"
5SRC_URI += "file://fixinstall.patch"
6
7inherit nativesdk
8
9do_configure_prepend () {
10 # Remove any existing libtool m4 since old stale versions would break
11 # any upgrade
12 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
13 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
14}
15
16do_install () {
17 autotools_do_install
18 install -d ${D}${bindir}/
19 install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/
20}
21
22SYSROOT_PREPROCESS_FUNCS += "libtoolnativesdk_sysroot_preprocess"
23
24libtoolnativesdk_sysroot_preprocess () {
25 install -d ${SYSROOT_DESTDIR}${bindir_crossscripts}/
26 install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${bindir_crossscripts}/${HOST_SYS}-libtool
27}