summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-native_2.4.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-native_2.4.6.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-native_2.4.6.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-native_2.4.6.bb b/meta/recipes-devtools/libtool/libtool-native_2.4.6.bb
new file mode 100644
index 0000000000..4c5218ade0
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-native_2.4.6.bb
@@ -0,0 +1,22 @@
1require libtool-${PV}.inc
2
3DEPENDS = ""
4
5SRC_URI += "file://prefix.patch"
6
7inherit native
8
9EXTRA_OECONF = " --with-libtool-sysroot=${STAGING_DIR_NATIVE}"
10
11do_configure_prepend () {
12 # Remove any existing libtool m4 since old stale versions would break
13 # any upgrade
14 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
15 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
16}
17
18do_install () {
19 autotools_do_install
20 install -d ${D}${bindir}/
21 install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
22}