summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-native_2.4.2.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-native_2.4.2.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
new file mode 100644
index 0000000000..f03859e061
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-native_2.4.2.bb
@@ -0,0 +1,23 @@
1require libtool-${PV}.inc
2
3DEPENDS = ""
4
5PR = "${INC_PR}.1"
6SRC_URI += "file://prefix.patch"
7
8inherit native
9
10EXTRA_OECONF = " --with-libtool-sysroot=${STAGING_DIR_NATIVE}"
11
12do_configure_prepend () {
13 # Remove any existing libtool m4 since old stale versions would break
14 # any upgrade
15 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
16 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
17}
18
19do_install () {
20 autotools_do_install
21 install -d ${D}${bindir}/
22 install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
23}