summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libtool/libtool-cross_2.2.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libtool/libtool-cross_2.2.10.bb')
-rw-r--r--meta/recipes-devtools/libtool/libtool-cross_2.2.10.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libtool/libtool-cross_2.2.10.bb b/meta/recipes-devtools/libtool/libtool-cross_2.2.10.bb
new file mode 100644
index 0000000000..23135f7edb
--- /dev/null
+++ b/meta/recipes-devtools/libtool/libtool-cross_2.2.10.bb
@@ -0,0 +1,34 @@
1require libtool_${PV}.bb
2
3PR = "r1"
4PACKAGES = ""
5SRC_URI_append = " file://cross_compile.patch \
6 file://prefix.patch "
7
8DEPENDS += "libtool-native"
9
10do_configure_prepend () {
11 # Remove any existing libtool m4 since old stale versions would break
12 # any upgrade
13 rm -f ${STAGING_DATADIR}/aclocal/libtool.m4
14 rm -f ${STAGING_DATADIR}/aclocal/lt*.m4
15}
16
17do_install () {
18 install -d ${D}${bindir}/
19 install -m 0755 ${HOST_SYS}-libtool ${D}${bindir}/${HOST_SYS}-libtool
20 install -d ${D}${datadir}/libtool/
21 install -d ${D}${datadir}/aclocal/
22 install -c ${S}/libltdl/config/config.guess ${D}${datadir}/libtool/
23 install -c ${S}/libltdl/config/config.sub ${D}${datadir}/libtool/
24 install -c -m 0644 ${S}/libltdl/config/ltmain.sh ${D}${datadir}/libtool/
25 install -c -m 0644 ${S}/libltdl/m4/libtool.m4 ${D}${datadir}/aclocal/
26 install -c -m 0644 ${S}/libltdl/m4/ltdl.m4 ${D}${datadir}/aclocal/
27}
28
29SYSROOT_PREPROCESS_FUNCS += "libtoolcross_sysroot_preprocess"
30
31libtoolcross_sysroot_preprocess () {
32 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/
33 install -m 755 ${D}${bindir}/${HOST_SYS}-libtool ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}/${HOST_SYS}-libtool
34}