summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/librepo/librepo_1.17.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/librepo/librepo_1.17.0.bb')
-rw-r--r--meta/recipes-devtools/librepo/librepo_1.17.0.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta/recipes-devtools/librepo/librepo_1.17.0.bb b/meta/recipes-devtools/librepo/librepo_1.17.0.bb
new file mode 100644
index 0000000000..810191459d
--- /dev/null
+++ b/meta/recipes-devtools/librepo/librepo_1.17.0.bb
@@ -0,0 +1,31 @@
1SUMMARY = "A library providing C and Python (libcURL like) API \
2 for downloading linux repository metadata and packages."
3HOMEPAGE = "https://github.com/rpm-software-management/librepo"
4DESCRIPTION = "${SUMMARY}"
5LICENSE = "LGPL-2.1-only"
6LIC_FILES_CHKSUM = "file://COPYING;md5=4fbd65380cdd255951079008b364516c"
7
8SRC_URI = "git://github.com/rpm-software-management/librepo.git;branch=master;protocol=https \
9 file://0002-Do-not-try-to-obtain-PYTHON_INSTALL_DIR-by-running-p.patch \
10 file://0004-Set-gpgme-variables-with-pkg-config-not-with-cmake-m.patch \
11 file://0001-gpg_gpgme.c-fix-build-errors-with-older-gcc.patch \
12 "
13
14SRCREV = "ae727d99086f70f39fba5695af5460e1da908c1b"
15
16S = "${WORKDIR}/git"
17
18DEPENDS = "curl glib-2.0 openssl attr gpgme libxml2"
19
20inherit cmake setuptools3-base pkgconfig
21
22EXTRA_OECMAKE = " \
23 -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} \
24 -DPYTHON_DESIRED=3 \
25 -DENABLE_TESTS=OFF \
26 -DENABLE_DOCS=OFF \
27 -DWITH_ZCHUNK=OFF \
28 -DENABLE_SELINUX=OFF \
29"
30
31BBCLASSEXTEND = "native nativesdk"