summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libcomps/libcomps_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libcomps/libcomps_git.bb')
-rw-r--r--meta/recipes-devtools/libcomps/libcomps_git.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libcomps/libcomps_git.bb b/meta/recipes-devtools/libcomps/libcomps_git.bb
new file mode 100644
index 0000000000..448ea62f67
--- /dev/null
+++ b/meta/recipes-devtools/libcomps/libcomps_git.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Libcomps is alternative for yum.comps library (which is for managing rpm package groups)."
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "git://github.com/rpm-software-management/libcomps.git \
6 file://0001-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
7 file://0002-Set-library-installation-path-correctly.patch \
8 "
9
10PV = "0.1.8+git${SRCPV}"
11SRCREV = "01a4759894cccff64d2561614a58281adf5ce859"
12
13S = "${WORKDIR}/git"
14
15inherit cmake distutils-base
16
17DEPENDS = "libxml2 expat libcheck"
18
19EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR}"
20OECMAKE_SOURCEPATH = "${S}/libcomps"
21
22BBCLASSEXTEND = "native"
23