summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/libcomps/libcomps_0.1.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/libcomps/libcomps_0.1.15.bb')
-rw-r--r--meta/recipes-devtools/libcomps/libcomps_0.1.15.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta/recipes-devtools/libcomps/libcomps_0.1.15.bb b/meta/recipes-devtools/libcomps/libcomps_0.1.15.bb
new file mode 100644
index 0000000000..98c55dca85
--- /dev/null
+++ b/meta/recipes-devtools/libcomps/libcomps_0.1.15.bb
@@ -0,0 +1,22 @@
1SUMMARY = "Libcomps is alternative for yum.comps library (which is for managing rpm package groups)."
2LICENSE = "GPLv2"
3LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4
5SRC_URI = "git://github.com/rpm-software-management/libcomps.git \
6 file://0001-Add-crc32.c-to-sources-list.patch \
7 file://0002-Do-not-set-PYTHON_INSTALL_DIR-by-running-python.patch \
8 "
9
10SRCREV = "b213f749405d84e989b25e183bcf28ce701696dd"
11
12S = "${WORKDIR}/git"
13
14inherit cmake distutils3-base
15
16DEPENDS += "libxml2 expat libcheck"
17
18EXTRA_OECMAKE = " -DPYTHON_INSTALL_DIR=${PYTHON_SITEPACKAGES_DIR} -DPYTHON_DESIRED=3"
19OECMAKE_SOURCEPATH = "${S}/libcomps"
20
21BBCLASSEXTEND = "native nativesdk"
22