diff options
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb')
-rw-r--r-- | meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb | 41 |
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb new file mode 100644 index 0000000000..d1fdc0e297 --- /dev/null +++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.6.bb | |||
@@ -0,0 +1,41 @@ | |||
1 | # Copyright (C) 2012 Khem Raj <raj.khem@gmail.com> | ||
2 | # Released under the MIT license (see COPYING.MIT for the terms) | ||
3 | |||
4 | DESCRIPTION = "The kconfig-frontends project aims at centralising \ | ||
5 | the effort of keeping an up-to-date, out-of-tree, packaging of the \ | ||
6 | kconfig infrastructure, ready for use by third-party projects. \ | ||
7 | The kconfig-frontends package provides the kconfig parser, as well as all \ | ||
8 | the frontends" | ||
9 | HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends" | ||
10 | LICENSE = "GPL-2.0" | ||
11 | LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408" | ||
12 | SECTION = "devel" | ||
13 | DEPENDS += "ncurses flex bison gperf" | ||
14 | PR = "r0" | ||
15 | PV = "3.6.0" | ||
16 | SPIN = "0" | ||
17 | SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BPN}-${PV}-${SPIN}.tar.xz" | ||
18 | |||
19 | SRC_URI[md5sum] = "91ca87abb3c99c3fd40a7babb05ec507" | ||
20 | SRC_URI[sha256sum] = "3084989a9b146688f318b5524dfb7ab3ba47c9cef355d1aebaa520befdb48da0" | ||
21 | |||
22 | S = "${WORKDIR}/${BPN}-${PV}-${SPIN}" | ||
23 | |||
24 | inherit autotools | ||
25 | do_configure_prepend () { | ||
26 | mkdir -p scripts/.autostuff/m4 | ||
27 | } | ||
28 | |||
29 | do_install_append() { | ||
30 | ln -s kconfig-conf ${D}${bindir}/conf | ||
31 | ln -s kconfig-mconf ${D}${bindir}/mconf | ||
32 | } | ||
33 | |||
34 | EXTRA_OECONF += "--disable-gconf --disable-qconf" | ||
35 | |||
36 | # Some packages have the version preceeding the .so instead properly | ||
37 | # versioned .so.<version>, so we need to reorder and repackage. | ||
38 | SOLIBS = "-${PV}.so" | ||
39 | FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so" | ||
40 | |||
41 | BBCLASSEXTEND = "native" | ||