summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb')
-rw-r--r--meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb
new file mode 100644
index 0000000000..ef0019fc7d
--- /dev/null
+++ b/meta/recipes-devtools/kconfig-frontends/kconfig-frontends_3.12.0.0.bb
@@ -0,0 +1,40 @@
1# Copyright (C) 2012 Khem Raj <raj.khem@gmail.com>
2# Released under the MIT license (see COPYING.MIT for the terms)
3
4SUMMARY = "Linux kernel style configuration framework for other projects"
5DESCRIPTION = "The kconfig-frontends project aims at centralising \
6the effort of keeping an up-to-date, out-of-tree, packaging of the \
7kconfig infrastructure, ready for use by third-party projects. \
8The kconfig-frontends package provides the kconfig parser, as well as all \
9the frontends"
10HOMEPAGE = "http://ymorin.is-a-geek.org/projects/kconfig-frontends"
11LICENSE = "GPL-2.0"
12LIC_FILES_CHKSUM = "file://COPYING;md5=9b8cf60ff39767ff04b671fca8302408"
13SECTION = "devel"
14DEPENDS += "ncurses flex bison gperf-native pkgconfig-native"
15RDEPENDS_${PN} += "python bash"
16SRC_URI = "http://ymorin.is-a-geek.org/download/${BPN}/${BP}.tar.xz"
17
18SRC_URI[md5sum] = "b939280dcc83f8feabd87a1d5f9b00c2"
19SRC_URI[sha256sum] = "ea2615a62c74bea6ce3b38402f00c7513858f307f6ba7aa9fdbf0bbc12bcf407"
20
21S = "${WORKDIR}/${BPN}-${PV}"
22
23inherit autotools
24do_configure_prepend () {
25 mkdir -p scripts/.autostuff/m4
26}
27
28do_install_append() {
29 ln -s kconfig-conf ${D}${bindir}/conf
30 ln -s kconfig-mconf ${D}${bindir}/mconf
31}
32
33EXTRA_OECONF += "--disable-gconf --disable-qconf"
34
35# Some packages have the version preceeding the .so instead properly
36# versioned .so.<version>, so we need to reorder and repackage.
37SOLIBS = "-${@d.getVar('PV',1)[:-2]}.so"
38FILES_SOLIBSDEV = "${libdir}/libkconfig-parser.so"
39
40BBCLASSEXTEND = "native"