summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/json-c/json-c_0.16.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/json-c/json-c_0.16.bb')
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.16.bb16
1 files changed, 14 insertions, 2 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.16.bb b/meta/recipes-devtools/json-c/json-c_0.16.bb
index fdec5ec9af..50431081bb 100644
--- a/meta/recipes-devtools/json-c/json-c_0.16.bb
+++ b/meta/recipes-devtools/json-c/json-c_0.16.bb
@@ -4,7 +4,10 @@ HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT" 4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2" 5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6 6
7SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz" 7SRC_URI = " \
8 https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz \
9 file://run-ptest \
10"
8 11
9SRC_URI[sha256sum] = "8e45ac8f96ec7791eaf3bb7ee50e9c2100bbbc87b8d0f1d030c5ba8a0288d96b" 12SRC_URI[sha256sum] = "8e45ac8f96ec7791eaf3bb7ee50e9c2100bbbc87b8d0f1d030c5ba8a0288d96b"
10 13
@@ -13,6 +16,15 @@ UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+)-\d+"
13 16
14RPROVIDES:${PN} = "libjson" 17RPROVIDES:${PN} = "libjson"
15 18
16inherit cmake 19inherit cmake ptest
20
21do_install_ptest() {
22 install -d ${D}/${PTEST_PATH}/tests
23 install ${B}/tests/test* ${D}/${PTEST_PATH}/tests
24 install ${S}/tests/*.test ${D}/${PTEST_PATH}/tests
25 install ${S}/tests/*.expected ${D}/${PTEST_PATH}/tests
26 install ${S}/tests/test-defs.sh ${D}/${PTEST_PATH}/tests
27 install ${S}/tests/valid*json ${D}/${PTEST_PATH}/tests
28}
17 29
18BBCLASSEXTEND = "native nativesdk" 30BBCLASSEXTEND = "native nativesdk"