summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/json-c/json-c_0.13.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/json-c/json-c_0.13.1.bb')
-rw-r--r--meta/recipes-devtools/json-c/json-c_0.13.1.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta/recipes-devtools/json-c/json-c_0.13.1.bb b/meta/recipes-devtools/json-c/json-c_0.13.1.bb
new file mode 100644
index 0000000000..5b10e68297
--- /dev/null
+++ b/meta/recipes-devtools/json-c/json-c_0.13.1.bb
@@ -0,0 +1,30 @@
1SUMMARY = "C bindings for apps which will manipulate JSON data"
2DESCRIPTION = "JSON-C implements a reference counting object model that allows you to easily construct JSON objects in C."
3HOMEPAGE = "https://github.com/json-c/json-c/wiki"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://COPYING;md5=de54b60fbbc35123ba193fea8ee216f2"
6
7SRC_URI = "https://s3.amazonaws.com/json-c_releases/releases/${BP}.tar.gz"
8SRC_URI[md5sum] = "04969ad59cc37bddd83741a08b98f350"
9SRC_URI[sha256sum] = "b87e608d4d3f7bfdd36ef78d56d53c74e66ab278d318b71e6002a369d36f4873"
10
11UPSTREAM_CHECK_REGEX = "json-c-(?P<pver>\d+(\.\d+)+).tar"
12# json-c releases page is fetching the list of releases in some weird XML format
13# from https://s3.amazonaws.com/json-c_releases and processes it with javascript :-/
14#UPSTREAM_CHECK_URI = "https://s3.amazonaws.com/json-c_releases/releases/index.html"
15RECIPE_UPSTREAM_VERSION = "0.13.1"
16RECIPE_UPSTREAM_DATE = "Mar 04, 2018"
17CHECK_DATE = "May 02, 2018"
18
19RPROVIDES_${PN} = "libjson"
20
21inherit autotools
22
23EXTRA_OECONF = "--enable-rdrand"
24
25do_configure_prepend() {
26 # Clean up autoconf cruft that should not be in the tarball
27 rm -f ${S}/config.status
28}
29
30BBCLASSEXTEND = "native nativesdk"