diff options
Diffstat (limited to 'meta/recipes-devtools/jquery/jquery_3.6.3.bb')
-rw-r--r-- | meta/recipes-devtools/jquery/jquery_3.6.3.bb | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/jquery/jquery_3.6.3.bb b/meta/recipes-devtools/jquery/jquery_3.6.3.bb new file mode 100644 index 0000000000..93f87f730d --- /dev/null +++ b/meta/recipes-devtools/jquery/jquery_3.6.3.bb | |||
@@ -0,0 +1,39 @@ | |||
1 | SUMMARY = "jQuery is a fast, small, and feature-rich JavaScript library" | ||
2 | HOMEPAGE = "https://jquery.com/" | ||
3 | DESCRIPTION = "${SUMMARY}" | ||
4 | LICENSE = "MIT" | ||
5 | SECTION = "devel" | ||
6 | LIC_FILES_CHKSUM = "file://${S}/${BP}.js;beginline=8;endline=10;md5=9c7c6e9ab275fc1e0d99cb7180ecd14c" | ||
7 | |||
8 | # unpack items to ${S} so the archiver can see them | ||
9 | # | ||
10 | SRC_URI = "\ | ||
11 | https://code.jquery.com/${BP}.js;name=js;subdir=${BP} \ | ||
12 | https://code.jquery.com/${BP}.min.js;name=min;subdir=${BP} \ | ||
13 | https://code.jquery.com/${BP}.min.map;name=map;subdir=${BP} \ | ||
14 | " | ||
15 | |||
16 | SRC_URI[js.sha256sum] = "9d02ee01919145c20b03ee9d3013af7118793dedf5d2c0696a773af90066c953" | ||
17 | SRC_URI[min.sha256sum] = "a6f3f0faea4b3d48e03176341bef0ed3151ffbf226d4c6635f1c6039c0500575" | ||
18 | SRC_URI[map.sha256sum] = "156b740931ade6c1a98d99713eeb186f93847ffc56057e973becab4d037ed53a" | ||
19 | |||
20 | UPSTREAM_CHECK_REGEX = "jquery-(?P<pver>\d+(\.\d+)+)\.js" | ||
21 | |||
22 | # https://github.com/jquery/jquery/issues/3927 | ||
23 | # There are ways jquery can expose security issues but any issues are in the apps exposing them | ||
24 | # and there is little we can directly do | ||
25 | CVE_CHECK_IGNORE += "CVE-2007-2379" | ||
26 | |||
27 | inherit allarch | ||
28 | |||
29 | do_install() { | ||
30 | install -d ${D}${datadir}/javascript/${BPN}/ | ||
31 | install -m 644 ${S}/${BP}.js ${D}${datadir}/javascript/${BPN}/${BPN}.js | ||
32 | install -m 644 ${S}/${BP}.min.js ${D}${datadir}/javascript/${BPN}/${BPN}.min.js | ||
33 | install -m 644 ${S}/${BP}.min.map ${D}${datadir}/javascript/${BPN}/${BPN}.min.map | ||
34 | } | ||
35 | |||
36 | PACKAGES = "${PN}" | ||
37 | FILES:${PN} = "${datadir}" | ||
38 | |||
39 | BBCLASSEXTEND += "native nativesdk" | ||