summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/insserv/insserv_1.14.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/insserv/insserv_1.14.0.bb')
-rw-r--r--meta/recipes-devtools/insserv/insserv_1.14.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/meta/recipes-devtools/insserv/insserv_1.14.0.bb b/meta/recipes-devtools/insserv/insserv_1.14.0.bb
new file mode 100644
index 0000000000..4a33e16912
--- /dev/null
+++ b/meta/recipes-devtools/insserv/insserv_1.14.0.bb
@@ -0,0 +1,41 @@
1SUMMARY = "Boot sequence organizer using LSB init.d dependencies"
2DESCRIPTION = "This utility reorders the init.d boot scripts based on dependencies given in scripts' LSB comment \
3headers, or in override files included in this package or added in /etc/insserv."
4# There is no known home page for insserv
5SECTION = "base"
6LICENSE = "GPLv2"
7LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
8
9PR = "r1"
10
11SRC_URI = "ftp://ftp.suse.com/pub/projects/init/${BPN}-${PV}.tar.bz2 \
12 file://makefile.patch \
13 file://disable_runtests.patch \
14 file://insserv.conf \
15 file://run-ptest \
16"
17
18SRC_URI[md5sum] = "4a97d900855148842b1aa8f33b988b47"
19SRC_URI[sha256sum] = "89a0a093b1cf3d802ad40568e64b496b493f51ff9825905c8bd12738b374ca47"
20
21do_install () {
22 oe_runmake 'DESTDIR=${D}' install
23 install -m0644 ${WORKDIR}/insserv.conf ${D}${sysconfdir}/insserv.conf
24}
25
26do_install_class-native () {
27 oe_runmake 'DESTDIR=${D}/${STAGING_DIR_NATIVE}' install
28 install -m0644 ${WORKDIR}/insserv.conf ${D}${sysconfdir}/insserv.conf
29}
30
31BBCLASSEXTEND = "native"
32
33inherit ptest
34
35do_install_ptest() {
36 for i in common suite; do cp ${S}/tests/$i ${D}${PTEST_PATH}; done
37 sed -e 's|${\PWD}/insserv|insserv|;/trap/d' -i ${D}${PTEST_PATH}/suite
38 sed -e '/test_simple_sequence$/d;/test_undetected_loop$/d' -i ${D}${PTEST_PATH}/common
39}
40
41RDEPENDS_${PN}-ptest += "bash"