summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb')
-rw-r--r--meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb39
1 files changed, 39 insertions, 0 deletions
diff --git a/meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb b/meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb
new file mode 100644
index 0000000000..e936fd759b
--- /dev/null
+++ b/meta/recipes-devtools/i2c-tools/i2c-tools_4.0.bb
@@ -0,0 +1,39 @@
1SUMMARY = "Set of i2c tools for linux"
2HOMEPAGE = "https://i2c.wiki.kernel.org/index.php/I2C_Tools"
3SECTION = "base"
4LICENSE = "GPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
6
7SRC_URI = "${KERNELORG_MIRROR}/software/utils/i2c-tools/${BP}.tar.gz \
8 file://0001-lib-Module.mk-Add-missing-dependencies.patch \
9 file://0001-tools-Module.mk-Add-missing-dependencies.patch \
10 file://0001-i2c-tools-eeprog-Module.mk-Add-missing-dependency.patch \
11"
12
13SRC_URI[md5sum] = "d92a288d70f306d3895e3a7e9c14c9aa"
14SRC_URI[sha256sum] = "5b60daf6f011de0acb61de57dba62f2054bb39f19961d67e0c91610f071ca403"
15
16inherit autotools-brokensep
17
18do_compile_prepend() {
19 sed -i 's#/usr/local#/usr#' ${S}/Makefile
20 echo "include eeprog/Module.mk" >> ${S}/Makefile
21}
22
23do_install_append() {
24 install -d ${D}${includedir}/linux
25 install -m 0644 include/linux/i2c-dev.h ${D}${includedir}/linux/i2c-dev-user.h
26 rm -f ${D}${includedir}/linux/i2c-dev.h
27}
28
29PACKAGES =+ "${PN}-misc"
30FILES_${PN}-misc = "${sbindir}/i2c-stub-from-dump \
31 ${bindir}/ddcmon \
32 ${bindir}/decode-edid \
33 ${bindir}/decode-dimms \
34 ${bindir}/decode-vaio \
35 "
36RDEPENDS_${PN}-misc = "${PN} perl perl-module-posix \
37 perl-module-constant perl-module-file-basename \
38 perl-module-fcntl perl-module-strict perl-module-vars \
39 "