summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/help2man/help2man-native_1.47.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/help2man/help2man-native_1.47.15.bb')
-rw-r--r--meta/recipes-devtools/help2man/help2man-native_1.47.15.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-devtools/help2man/help2man-native_1.47.15.bb b/meta/recipes-devtools/help2man/help2man-native_1.47.15.bb
new file mode 100644
index 0000000000..4f80a2bdb1
--- /dev/null
+++ b/meta/recipes-devtools/help2man/help2man-native_1.47.15.bb
@@ -0,0 +1,23 @@
1SUMMARY = "Program for creating simple man pages"
2SECTION = "devel"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=1ebbd3e34237af26da5dc08a4e440464"
5DEPENDS = "autoconf-native automake-native"
6
7SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
8SRC_URI[sha256sum] = "c25a35b30eceb315361484b0ff1f81c924e8ee5c8881576f1ee762f001dbcd1c"
9
10inherit autotools native
11
12EXTRA_OECONF = "--disable-nls"
13
14# We don't want to reconfigure things as it would require 'perlnative' to be
15# used.
16do_configure() {
17 oe_runconf
18}
19
20do_install_append () {
21 # Make sure we use /usr/bin/env perl
22 sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
23}