summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/help2man/help2man-native_1.47.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/help2man/help2man-native_1.47.11.bb')
-rw-r--r--meta/recipes-devtools/help2man/help2man-native_1.47.11.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-devtools/help2man/help2man-native_1.47.11.bb b/meta/recipes-devtools/help2man/help2man-native_1.47.11.bb
new file mode 100644
index 0000000000..a60e851897
--- /dev/null
+++ b/meta/recipes-devtools/help2man/help2man-native_1.47.11.bb
@@ -0,0 +1,24 @@
1SUMMARY = "Program for creating simple man pages"
2SECTION = "devel"
3LICENSE = "GPLv3"
4LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
5DEPENDS = "autoconf-native automake-native"
6
7SRC_URI = "${GNU_MIRROR}/${BPN}/${BPN}-${PV}.tar.xz"
8SRC_URI[md5sum] = "dd322adcaede5bd5eaed075ff8971bc1"
9SRC_URI[sha256sum] = "5985b257f86304c8791842c0c807a37541d0d6807ee973000cf8a3fe6ad47b88"
10
11inherit autotools native
12
13EXTRA_OECONF = "--disable-nls"
14
15# We don't want to reconfigure things as it would require 'perlnative' to be
16# used.
17do_configure() {
18 oe_runconf
19}
20
21do_install_append () {
22 # Make sure we use /usr/bin/env perl
23 sed -i -e "1s:#!.*:#! /usr/bin/env perl:" ${D}${bindir}/help2man
24}