summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/guile/guile_2.0.7.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/guile/guile_2.0.7.bb')
-rw-r--r--meta/recipes-devtools/guile/guile_2.0.7.bb102
1 files changed, 102 insertions, 0 deletions
diff --git a/meta/recipes-devtools/guile/guile_2.0.7.bb b/meta/recipes-devtools/guile/guile_2.0.7.bb
new file mode 100644
index 0000000000..7f3316a893
--- /dev/null
+++ b/meta/recipes-devtools/guile/guile_2.0.7.bb
@@ -0,0 +1,102 @@
1SUMMARY = "Guile is the GNU Ubiquitous Intelligent Language for Extensions."
2DESCRIPTION = "Guile is the GNU Ubiquitous Intelligent Language for Extensions,\
3 the official extension language for the GNU operating system.\
4 Guile is a library designed to help programmers create flexible applications.\
5 Using Guile in an application allows the application's functionality to be\
6 extended by users or other programmers with plug-ins, modules, or scripts.\
7 Guile provides what might be described as 'practical software freedom,'\
8 making it possible for users to customize an application to meet their\
9 needs without digging into the application's internals."
10
11HOMEPAGE = "http://www.gnu.org/software/guile/"
12SECTION = "devel"
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15
16SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.xz \
17 file://debian/0002-Mark-Unused-modules-are-removed-gc-test-as-unresolve.patch \
18 file://debian/0003-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch \
19 file://opensuse/guile-64bit.patch \
20 file://guile_2.0.6_fix_sed_error.patch \
21 file://arm_endianness.patch \
22 "
23
24# file://debian/0001-Change-guile-to-guile-X.Y-for-info-pages.patch
25# file://opensuse/guile-turn-off-gc-test.patch
26
27SRC_URI[md5sum] = "30ff9e94663a2e2098b52f8ce9d050b9"
28SRC_URI[sha256sum] = "6f278fa699685382ae51ba8bfad5840959e0af6414f3ad803d61131567bfa338"
29
30PR = "r0"
31
32inherit autotools gettext
33BBCLASSEXTEND = "native"
34
35DEPENDS = "libunistring bdwgc gmp libtool libffi"
36# add guile-native only to the target recipe's DEPENDS
37DEPENDS += "${@['guile-native libatomics-ops', ''][d.getVar('PN', True) != 'guile']}"
38
39EXTRA_OECONF += "${@['--without-libltdl-prefix --without-libgmp-prefix', ''][bb.data.inherits_class('native',d)]}"
40
41do_configure_prepend() {
42 mkdir -p po
43}
44
45export GUILE_FOR_BUILD="${BUILD_SYS}-guile"
46
47do_compile_append() {
48 # just for target recipe
49 if [ "${PN}" = "guile" ]
50 then
51 sed -i -e s:${STAGING_DIR_TARGET}::g \
52 -e s:/${TARGET_SYS}::g \
53 -e s:-L/usr/lib::g \
54 -e s:-isystem/usr/include::g \
55 -e s:,/usr/lib:,\$\{libdir\}:g \
56 meta/guile-2.0.pc
57 fi
58}
59
60do_install_append_class-native() {
61 install -m 0755 ${D}${bindir}/guile ${D}${bindir}/${HOST_SYS}-guile
62
63 create_wrapper ${D}/${bindir}/guile \
64 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
65 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
66 create_wrapper ${D}${bindir}/${HOST_SYS}-guile \
67 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
68 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
69}
70
71SYSROOT_PREPROCESS_FUNCS = "guile_cross_config"
72
73guile_cross_config() {
74 # this is only for target recipe
75 if [ "${PN}" = "guile" ]
76 then
77 # Create guile-config returning target values instead of native values
78 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}
79 echo '#!'`which ${BUILD_SYS}-guile`$' \\\n--no-auto-compile -e main -s\n!#\n(define %guile-build-info '\'\( \
80 > guile-config.cross
81 sed -n -e 's:^[ \t]*{[ \t]*": (:' \
82 -e 's:",[ \t]*": . ":' \
83 -e 's:" *}, *\\:"):' \
84 -e 's:^.*cachedir.*$::' \
85 -e '/^ (/p' \
86 < libguile/libpath.h >> guile-config.cross
87 echo '))' >> guile-config.cross
88 cat meta/guile-config >> guile-config.cross
89 install guile-config.cross ${STAGING_BINDIR_CROSS}/guile-config
90 fi
91}
92
93# Guile needs the compiled files to be newer than the source, and it won't
94# auto-compile into the prefix even if it can write there, so touch them here as
95# sysroot is managed.
96SSTATEPOSTINSTFUNCS += "guile_sstate_postinst"
97guile_sstate_postinst() {
98 if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
99 then
100 find ${STAGING_DIR_TARGET}/${libdir}/guile/2.0/ccache -type f | xargs touch
101 fi
102}