summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/guile/guile_2.0.12.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/guile/guile_2.0.12.bb')
-rw-r--r--meta/recipes-devtools/guile/guile_2.0.12.bb121
1 files changed, 121 insertions, 0 deletions
diff --git a/meta/recipes-devtools/guile/guile_2.0.12.bb b/meta/recipes-devtools/guile/guile_2.0.12.bb
new file mode 100644
index 0000000000..d2fe511ae4
--- /dev/null
+++ b/meta/recipes-devtools/guile/guile_2.0.12.bb
@@ -0,0 +1,121 @@
1SUMMARY = "Guile is the GNU Ubiquitous Intelligent Language for Extensions"
2DESCRIPTION = "Guile is the GNU Ubiquitous Intelligent Language for Extensions,\
3 the official extension language for the GNU operating system.\
4 Guile is a library designed to help programmers create flexible applications.\
5 Using Guile in an application allows the application's functionality to be\
6 extended by users or other programmers with plug-ins, modules, or scripts.\
7 Guile provides what might be described as 'practical software freedom,'\
8 making it possible for users to customize an application to meet their\
9 needs without digging into the application's internals."
10
11HOMEPAGE = "http://www.gnu.org/software/guile/"
12SECTION = "devel"
13LICENSE = "GPLv3"
14LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
15
16SRC_URI = "${GNU_MIRROR}/guile/guile-${PV}.tar.xz \
17 file://debian/0002-Mark-Unused-modules-are-removed-gc-test-as-unresolve.patch \
18 file://debian/0003-Mark-mutex-with-owner-not-retained-threads-test-as-u.patch \
19 file://opensuse/guile-64bit.patch \
20 file://guile_2.0.6_fix_sed_error.patch \
21 file://arm_endianness.patch \
22 file://arm_aarch64.patch \
23 file://workaround-ice-ssa-corruption.patch \
24 file://libguile-Makefile.am-hook.patch \
25 file://0002-Recognize-nios2-as-compilation-target.patch \
26 "
27
28SRC_URI[md5sum] = "081fdf80cd3a76f260a2a0d87f773d6b"
29SRC_URI[sha256sum] = "de8187736f9b260f2fa776ed39b52cb74dd389ccf7039c042f0606270196b7e9"
30
31inherit autotools gettext pkgconfig texinfo
32BBCLASSEXTEND = "native"
33
34DEPENDS = "libunistring bdwgc gmp libtool libffi ncurses readline"
35# add guile-native only to the target recipe's DEPENDS
36DEPENDS_append_class-target = " guile-native libatomic-ops"
37
38# The comment of the script guile-config said it has been deprecated but we should
39# at least add the required dependency to make it work since we still provide the script.
40RDEPENDS_${PN} = "pkgconfig"
41
42RDEPENDS_${PN}_append_libc-glibc_class-target = " glibc-gconv-iso8859-1"
43
44EXTRA_OECONF += "${@['--without-libltdl-prefix --without-libgmp-prefix --without-libreadline-prefix', ''][bb.data.inherits_class('native',d)]}"
45
46EXTRA_OECONF_append_class-target = " --with-libunistring-prefix=${STAGING_LIBDIR} \
47 --with-libgmp-prefix=${STAGING_LIBDIR} \
48 --with-libltdl-prefix=${STAGING_LIBDIR}"
49EXTRA_OECONF_append_libc-uclibc = " guile_cv_use_csqrt=no "
50
51CFLAGS_append_libc-musl = " -DHAVE_GC_SET_FINALIZER_NOTIFIER \
52 -DHAVE_GC_GET_HEAP_USAGE_SAFE \
53 -DHAVE_GC_GET_FREE_SPACE_DIVISOR \
54 -DHAVE_GC_SET_FINALIZE_ON_DEMAND \
55 "
56
57do_configure_prepend() {
58 mkdir -p po
59}
60
61export GUILE_FOR_BUILD="${BUILD_SYS}-guile"
62
63do_install_append_class-native() {
64 install -m 0755 ${D}${bindir}/guile ${D}${bindir}/${HOST_SYS}-guile
65
66 create_wrapper ${D}/${bindir}/guile \
67 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
68 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
69 create_wrapper ${D}${bindir}/${HOST_SYS}-guile \
70 GUILE_LOAD_PATH=${STAGING_DATADIR_NATIVE}/guile/2.0 \
71 GUILE_LOAD_COMPILED_PATH=${STAGING_LIBDIR_NATIVE}/guile/2.0/ccache
72}
73
74do_install_append_class-target() {
75 # cleanup buildpaths in scripts
76 sed -i -e 's:${STAGING_DIR_NATIVE}::' ${D}${bindir}/guile-config
77 sed -i -e 's:${STAGING_DIR_HOST}::' ${D}${bindir}/guile-snarf
78
79 sed -i -e 's:${STAGING_DIR_TARGET}::g' ${D}${libdir}/pkgconfig/guile-2.0.pc
80}
81
82do_install_append_libc-musl() {
83 rm -f ${D}${libdir}/charset.alias
84}
85
86SYSROOT_PREPROCESS_FUNCS = "guile_cross_config"
87
88guile_cross_config() {
89 # this is only for target recipe
90 if [ "${PN}" = "guile" ]
91 then
92 # Create guile-config returning target values instead of native values
93 install -d ${SYSROOT_DESTDIR}${STAGING_BINDIR_CROSS}
94 echo '#!'`which ${BUILD_SYS}-guile`$' \\\n--no-auto-compile -e main -s\n!#\n(define %guile-build-info '\'\( \
95 > ${B}/guile-config.cross
96 sed -n -e 's:^[ \t]*{[ \t]*": (:' \
97 -e 's:",[ \t]*": . ":' \
98 -e 's:" *}, *\\:"):' \
99 -e 's:^.*cachedir.*$::' \
100 -e '/^ (/p' \
101 < ${B}/libguile/libpath.h >> ${B}/guile-config.cross
102 echo '))' >> ${B}/guile-config.cross
103 cat ${B}/meta/guile-config >> ${B}/guile-config.cross
104 install ${B}/guile-config.cross ${STAGING_BINDIR_CROSS}/guile-config
105 fi
106}
107
108# Guile needs the compiled files to be newer than the source, and it won't
109# auto-compile into the prefix even if it can write there, so touch them here as
110# sysroot is managed.
111SSTATEPOSTINSTFUNCS += "guile_sstate_postinst"
112guile_sstate_postinst() {
113 if [ "${BB_CURRENTTASK}" = "populate_sysroot" -o "${BB_CURRENTTASK}" = "populate_sysroot_setscene" ]
114 then
115 find ${STAGING_DIR_TARGET}/${libdir}/guile/2.0/ccache -type f | xargs touch
116 fi
117}
118
119# http://errors.yoctoproject.org/Errors/Details/20491/
120ARM_INSTRUCTION_SET_armv4 = "arm"
121ARM_INSTRUCTION_SET_armv5 = "arm"