summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.9.bb28
1 files changed, 0 insertions, 28 deletions
diff --git a/meta/recipes-devtools/go/go_1.9.bb b/meta/recipes-devtools/go/go_1.9.bb
deleted file mode 100644
index c23ea0c1ae..0000000000
--- a/meta/recipes-devtools/go/go_1.9.bb
+++ /dev/null
@@ -1,28 +0,0 @@
1require go-${PV}.inc
2require go-target.inc
3
4export GO_TARGET_INSTALL = "cmd"
5export GO_FLAGS = "-a"
6export CC_FOR_TARGET = "${CC}"
7export CXX_FOR_TARGET = "${CXX}"
8export GOBUILDMODE=""
9
10do_compile() {
11 export GOBIN="${B}/bin"
12 export TMPDIR="$GOTMPDIR"
13 export CC=$BUILD_CC
14
15 cd src
16 ./make.bash
17 cd ${B}
18}
19
20# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips
21# doesn't support -buildmode=pie, so skip the QA checking for mips and its
22# variants.
23python() {
24 if 'mips' in d.getVar('TARGET_ARCH'):
25 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
26 else:
27 d.setVar('GOBUILDMODE', 'pie')
28}