summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.9.bb16
1 files changed, 10 insertions, 6 deletions
diff --git a/meta/recipes-devtools/go/go_1.9.bb b/meta/recipes-devtools/go/go_1.9.bb
index 7da7897cf5..c23ea0c1ae 100644
--- a/meta/recipes-devtools/go/go_1.9.bb
+++ b/meta/recipes-devtools/go/go_1.9.bb
@@ -5,6 +5,7 @@ export GO_TARGET_INSTALL = "cmd"
5export GO_FLAGS = "-a" 5export GO_FLAGS = "-a"
6export CC_FOR_TARGET = "${CC}" 6export CC_FOR_TARGET = "${CC}"
7export CXX_FOR_TARGET = "${CXX}" 7export CXX_FOR_TARGET = "${CXX}"
8export GOBUILDMODE=""
8 9
9do_compile() { 10do_compile() {
10 export GOBIN="${B}/bin" 11 export GOBIN="${B}/bin"
@@ -16,9 +17,12 @@ do_compile() {
16 cd ${B} 17 cd ${B}
17} 18}
18 19
19# for aarch64 ends with textrel in ${PN} 20# Add pie to GOBUILDMODE to satisfy "textrel" QA checking, but mips
20# http://errors.yoctoproject.org/Errors/Details/185634/ 21# doesn't support -buildmode=pie, so skip the QA checking for mips and its
21# ERROR: QA Issue: ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/bin/go' has relocations in .text 22# variants.
22# ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/pkg/tool/linux_arm64/trace' has relocations in .text 23python() {
23# ELF binary '/work/aarch64-oe-linux/go/1.9.7-r0/packages-split/go/usr/lib/go/pkg/tool/linux_arm64/pprof' has relocations in .text [textrel] 24 if 'mips' in d.getVar('TARGET_ARCH'):
24INSANE_SKIP_${PN} += "textrel" 25 d.appendVar('INSANE_SKIP_%s' % d.getVar('PN'), " textrel")
26 else:
27 d.setVar('GOBUILDMODE', 'pie')
28}