summaryrefslogtreecommitdiffstats
path: root/meta/recipes-devtools/go/go_1.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-devtools/go/go_1.9.bb')
-rw-r--r--meta/recipes-devtools/go/go_1.9.bb15
1 files changed, 15 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.9.bb b/meta/recipes-devtools/go/go_1.9.bb
index c67e2cb050..ec5a314e7d 100644
--- a/meta/recipes-devtools/go/go_1.9.bb
+++ b/meta/recipes-devtools/go/go_1.9.bb
@@ -1,2 +1,17 @@
1require go-${PV}.inc 1require go-${PV}.inc
2require go-target.inc 2require go-target.inc
3
4export GO_TARGET_INSTALL = "cmd"
5export GO_FLAGS = "-a"
6export CC_FOR_TARGET = "${CC}"
7export CXX_FOR_TARGET = "${CXX}"
8
9do_compile() {
10 export GOBIN="${B}/bin"
11 export TMPDIR="$GOTMPDIR"
12 export CC=$BUILD_CC
13
14 cd src
15 ./make.bash
16 cd ${B}
17}