diff options
Diffstat (limited to 'meta/recipes-devtools/go/go_1.20.7.bb')
-rw-r--r-- | meta/recipes-devtools/go/go_1.20.7.bb | 18 |
1 files changed, 18 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.20.7.bb b/meta/recipes-devtools/go/go_1.20.7.bb new file mode 100644 index 0000000000..46f5fbc6be --- /dev/null +++ b/meta/recipes-devtools/go/go_1.20.7.bb | |||
@@ -0,0 +1,18 @@ | |||
1 | require go-${PV}.inc | ||
2 | require go-target.inc | ||
3 | |||
4 | inherit linuxloader | ||
5 | |||
6 | CGO_LDFLAGS:append = " -no-pie" | ||
7 | |||
8 | export GO_LDSO = "${@get_linuxloader(d)}" | ||
9 | export CC_FOR_TARGET = "gcc" | ||
10 | export CXX_FOR_TARGET = "g++" | ||
11 | |||
12 | # mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its | ||
13 | # variants. | ||
14 | python() { | ||
15 | if 'mips' in d.getVar('TARGET_ARCH') or 'riscv32' in d.getVar('TARGET_ARCH'): | ||
16 | d.appendVar('INSANE_SKIP:%s' % d.getVar('PN'), " textrel") | ||
17 | } | ||
18 | |||