diff options
Diffstat (limited to 'meta/recipes-devtools/go/go_1.17.3.bb')
-rw-r--r-- | meta/recipes-devtools/go/go_1.17.3.bb | 17 |
1 files changed, 17 insertions, 0 deletions
diff --git a/meta/recipes-devtools/go/go_1.17.3.bb b/meta/recipes-devtools/go/go_1.17.3.bb new file mode 100644 index 0000000000..34dc89bb0c --- /dev/null +++ b/meta/recipes-devtools/go/go_1.17.3.bb | |||
@@ -0,0 +1,17 @@ | |||
1 | require go-${PV}.inc | ||
2 | require go-target.inc | ||
3 | |||
4 | inherit linuxloader | ||
5 | |||
6 | export GOBUILDMODE="" | ||
7 | export GO_LDSO = "${@get_linuxloader(d)}" | ||
8 | export CC_FOR_TARGET = "gcc" | ||
9 | export CXX_FOR_TARGET = "g++" | ||
10 | |||
11 | # mips/rv64 doesn't support -buildmode=pie, so skip the QA checking for mips/riscv32 and its | ||
12 | # variants. | ||
13 | python() { | ||
14 | if 'mips' in d.getVar('TARGET_ARCH',True) or 'riscv32' in d.getVar('TARGET_ARCH',True): | ||
15 | d.appendVar('INSANE_SKIP:%s' % d.getVar('PN',True), " textrel") | ||
16 | } | ||
17 | |||